CVE-2015-7503GHSA-PM9M-W23Q-5967
Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.5.2, 2.4.9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA private key.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- zendframework/zendframeworkPackagist
From 2.5.0 · fixed in 2.5.2
- zendframework/zend-cryptPackagist
From 2.0.0 · fixed in 2.4.9
- zendframework/zend-cryptPackagist
From 2.5.0 · fixed in 2.5.2
- zendframework/zendframeworkPackagist
From 2.0.0 · fixed in 2.4.9