CVE-2015-5963GHSA-PGXH-WFW4-JX2VPYSEC-2015-22
contrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other ver
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.8.4, 1.7.10, 1.4.22
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
contrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions allows remote attackers to cause a denial of service (session store consumption or session record removal) via a large number of requests to contrib.auth.views.logout, which triggers the creation of an empty session record.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- djangoPyPI
From 1.8 · fixed in 1.8.4
- djangoPyPI
From 1.7 · fixed in 1.7.10
- djangoPyPI
From 1.4 · fixed in 1.4.22
- djangoPyPI
From 1.8 · fixed in 1.8.4; From 1.7 · fixed in 1.7.10; From 1.4 · fixed in 1.4.22