Skip to main content
← All vulnerabilities
CVE-2015-5342GHSA-6XPM-Q8X9-J3RW

The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote authenticated user

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.11, 2.8.9, 2.9.3
None on Exploit-DB, Metasploit or GitHub

Summary

The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote authenticated users to bypass intended access restrictions by visiting a URL to add or delete responses in the closed state.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.7.11

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.9

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.3

References 2

moodle.org

git.moodle.org