CVE-2015-5340GHSA-MMVJ-J7HQ-RX85
Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not consider the moodle/badges:viewbadges capabi
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.11, 2.8.9, 2.9.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not consider the moodle/badges:viewbadges capability, which allows remote authenticated users to obtain sensitive badge information via a request involving (1) badges/overview.php or (2) badges/view.php.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- moodle/moodlePackagist
through 2.6.11
- moodle/moodlePackagist
From 2.7.0 · fixed in 2.7.11
- moodle/moodlePackagist
From 2.8.0 · fixed in 2.8.9
- moodle/moodlePackagist
From 2.9.0 · fixed in 2.9.3