Skip to main content
← All vulnerabilities
CVE-2015-5338GHSA-V33X-Q8GH-4X42

Multiple cross-site request forgery (CSRF) vulnerabilities in the lesson module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.11, 2.8.9, 2.9.3
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site request forgery (CSRF) vulnerabilities in the lesson module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allow remote attackers to hijack the authentication of arbitrary users for requests to (1) mod/lesson/mediafile.php or (2) mod/lesson/view.php.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.7.11

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.9

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.3

References 2

git.moodle.org

moodle.org