Skip to main content
← All vulnerabilities
CVE-2015-5337GHSA-2HW6-6RGF-726V

Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly restrict the availability of Flowpl

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.11, 2.8.9, 2.9.3
None on Exploit-DB, Metasploit or GitHub

Summary

Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly restrict the availability of Flowplayer, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted .swf file.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    through 2.6.11

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.11

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.9

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.3

References 2

git.moodle.org

moodle.org