Skip to main content
← All vulnerabilities
CVE-2015-5325GHSA-X2Q2-8PWQ-FR5R

Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP slav

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.625.2, 1.638
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP slave. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3665.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 1.625.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 1.626 · fixed in 1.638

References 3

rhn.redhat.com

access.redhat.com

wiki.jenkins-ci.org