Skip to main content
← All vulnerabilities
CVE-2015-5268GHSA-H34C-PX28-RJGW

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based author

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.10, 2.8.8, 2.9.2
None on Exploit-DB, Metasploit or GitHub

Summary

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.7.10

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.8

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.2

References 4

moodle.org

openwall.com

git.moodle.org

securitytracker.com