Skip to main content
← All vulnerabilities
CVE-2015-5265GHSA-44XP-WJ24-9XXJ

The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.10, 2.8.8, 2.9.2
None on Exploit-DB, Metasploit or GitHub

Summary

The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.10

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.8

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.2

References 4

git.moodle.org

openwall.com

moodle.org

securitytracker.com