Skip to main content
← All vulnerabilities
CVE-2015-5264GHSA-MM9Q-3847-M48X

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated user

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.10, 2.8.8, 2.9.2
None on Exploit-DB, Metasploit or GitHub

Summary

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.10

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.8

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.2

References 4

git.moodle.org

openwall.com

securitytracker.com

moodle.org