CVE-2015-5243GHSA-C95F-27GX-6VQ9
phpWhois allows remote attackers to execute arbitrary code via a crafted whois record.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.1.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
phpWhois allows remote attackers to execute arbitrary code via a crafted whois record.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- jsmitty12/phpwhoisPackagist
fixed in 5.1.0
- phpwhois/phpwhoisPackagist
through 4.2.5
- brightlocal/phpwhoisPackagist
through 4.2.5
- david-garcia/phpwhoisPackagist
through 4.3.1
- ivankristianto/phpwhoisPackagist
through 4.3.0
- kazist/phpwhoisPackagist
through 4.2.6
- serluck/phpwhoisPackagist
through 4.2.6
- simple-updates/phpwhoisPackagist
through 1.0.0
- truckersmp/phpwhoisPackagist
through 4.3.1