CVE-2015-5161GHSA-XP8P-9RQ5-4WGV
The Zend_Xml_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when runnin
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.4.6, 2.5.2, 1.12.14, 1.0.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 2 on Exploit-DB
Summary
The Zend_Xml_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.
Timeline
- Public exploit on Exploit-DB
EDB-37765, EDB-38573
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- zendframework/zendframeworkPackagist
From 2.0.0 · fixed in 2.4.6
- zendframework/zendframeworkPackagist
From 2.5.0 · fixed in 2.5.2
- zendframework/zendframework1Packagist
From 1.12.0 · fixed in 1.12.14
- zendframework/zendxmlPackagist
From 1.0.0 · fixed in 1.0.1
- zendframework/zendframeworkPackagist
From 1.12.0 · fixed in 1.12.14