Skip to main content
← All vulnerabilities
CVE-2015-5144GHSA-Q5QW-4364-5HHMPYSEC-2015-10

Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows rem

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.4.21, 1.7.9, 1.8.3
None on Exploit-DB, Metasploit or GitHub

Summary

Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows remote attackers to inject arbitrary headers and conduct HTTP response splitting attacks via a newline character in an (1) email message to the EmailValidator, a (2) URL to the URLValidator, or unspecified vectors to the (3) validate_ipv4_address or (4) validate_slug validator.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • djangoPyPI

    fixed in 1.4.21

  • djangoPyPI

    From 1.5 · fixed in 1.7.9

  • djangoPyPI

    From 1.8a1 · fixed in 1.8.3

  • djangoPyPI

    fixed in 1.4.21; From 1.5 · fixed in 1.7.9; From 1.8 · fixed in 1.8.3

References 10

lists.fedoraproject.org

security.gentoo.org

djangoproject.com

lists.opensuse.org

debian.org

securityfocus.com

ubuntu.com

securitytracker.com

oracle.com