Skip to main content
← All vulnerabilities
CVE-2015-5143PYSEC-2015-20GHSA-H582-2PCH-3XV3

The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cau

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.4.21, 1.7.9, 1.8.3
None on Exploit-DB, Metasploit or GitHub

Summary

The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cause a denial of service (session store consumption) via multiple requests with unique session keys.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • djangoPyPI

    fixed in 1.4.21; From 1.5 · fixed in 1.7.9; From 1.8 · fixed in 1.8.3

  • djangoPyPI

    fixed in 1.4.21

  • djangoPyPI

    From 1.5 · fixed in 1.7.9

  • djangoPyPI

    From 1.8 · fixed in 1.8.3

References 12

lists.fedoraproject.org

security.gentoo.org

djangoproject.com

lists.opensuse.org

debian.org

rhn.redhat.com

securityfocus.com

ubuntu.com

securitytracker.com

oracle.com