CVE-2015-3274GHSA-F7QM-Q26P-6RR2
Cross-site scripting (XSS) vulnerability in the user_get_user_details function in user/lib.php in Moodle through 2.6.11, 2.7.x before 2.7.9,
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.9, 2.8.7, 2.9.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site scripting (XSS) vulnerability in the user_get_user_details function in user/lib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to inject arbitrary web script or HTML by leveraging absence of an external_format_text call in a web service.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- moodle/moodlePackagist
From 2.7.0 · fixed in 2.7.9
- moodle/moodlePackagist
From 2.8.0 · fixed in 2.8.7
- moodle/moodlePackagist
From 2.9.0 · fixed in 2.9.1