Skip to main content
← All vulnerabilities
CVE-2015-3227GHSA-J96R-XVJQ-R9PG

The (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before 4.1.11 and 4.2.x before 4.2.2, when JDOM or REXML is e

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.11, 4.2.2, 3.2.22
None on Exploit-DB, Metasploit or GitHub

Summary

The (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before 4.1.11 and 4.2.x before 4.2.2, when JDOM or REXML is enabled, allow remote attackers to cause a denial of service (SystemStackError) via a large XML document depth.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • activesupportRubyGems

    From 4.0.0.beta1 · fixed in 4.1.11

  • activesupportRubyGems

    From 4.2.0.beta1 · fixed in 4.2.2

  • activesupportRubyGems

    fixed in 3.2.22

References 6

securitytracker.com

securityfocus.com

groups.google.com

lists.opensuse.org

debian.org

openwall.com