Skip to main content
← All vulnerabilities
CVE-2015-3226GHSA-VXVP-4XWC-JPP6

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.11, 4.2.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • activesupportRubyGems

    From 4.1.0 · fixed in 4.1.11

  • activesupportRubyGems

    From 4.2.0 · fixed in 4.2.2

References 5

securitytracker.com

groups.google.com

securityfocus.com

openwall.com

debian.org