CVE-2015-3225GHSA-RGR4-9JH5-J4J6
lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote atta
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.5.4, 1.6.2, 1.4.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- rackRubyGems
From 1.5.0 · fixed in 1.5.4
- rackRubyGems
From 1.6.0 · fixed in 1.6.2
- rackRubyGems
From 1.4.0 · fixed in 1.4.6