Skip to main content
← All vulnerabilities
CVE-2015-3180GHSA-688P-PGJ4-77HH

lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated u

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.11, 2.7.8, 2.8.6
None on Exploit-DB, Metasploit or GitHub

Summary

lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.11

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.8

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.6

References 5

moodle.org

securityfocus.com

securitytracker.com

openwall.com

git.moodle.org