Skip to main content
← All vulnerabilities
CVE-2015-3178GHSA-9FMW-M4QX-6CQ8

Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.11, 2.7.8, 2.8.6
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.11

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.8

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.6

References 5

git.moodle.org

securitytracker.com

moodle.org

securityfocus.com

openwall.com