Skip to main content
← All vulnerabilities
CVE-2015-3174GHSA-6R7X-6Q98-QCQP

mod/quiz/db/access.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not set the RISK_XSS bi

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.11, 2.7.8, 2.8.6
None on Exploit-DB, Metasploit or GitHub

Summary

mod/quiz/db/access.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not set the RISK_XSS bit for graders, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks via crafted gradebook feedback during manual quiz grading.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.11

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.8

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.6

References 5

securitytracker.com

git.moodle.org

moodle.org

openwall.com

securityfocus.com