Skip to main content
← All vulnerabilities
CVE-2015-2317PYSEC-2015-9GHSA-7FQ8-4PV5-5W5C

The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.4.20, 1.6.11, 1.7.7, 1.8c1
None on Exploit-DB, Metasploit or GitHub

Summary

The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a control character in a URL, as demonstrated by a \x08javascript: URL.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • djangoPyPI

    fixed in 1.4.20; From 1.5 · fixed in 1.6.11; From 1.7 · fixed in 1.7.7; From 1.8a0 · fixed in 1.8c1

  • djangoPyPI

    fixed in 1.4.20

  • djangoPyPI

    From 1.5 · fixed in 1.6.11

  • djangoPyPI

    From 1.7 · fixed in 1.7.7

  • djangoPyPI

    From 1.8a1 · fixed in 1.8c1

References 10

ubuntu.com

securityfocus.com

debian.org

lists.fedoraproject.org

lists.opensuse.org

oracle.com

mandriva.com

djangoproject.com