CVE-2015-2308GHSA-5C58-W9XC-QCJ9
Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x bef
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.27, 2.5.11, 2.6.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- symfony/symfonyPackagist
From 2.0.0 · fixed in 2.3.27
- symfony/symfonyPackagist
From 2.4.0 · fixed in 2.5.11
- symfony/symfonyPackagist
From 2.6.0 · fixed in 2.6.6
- symfony/http-kernelPackagist
From 2.0.0 · fixed in 2.3.27
- symfony/http-kernelPackagist
From 2.4.0 · fixed in 2.5.11
- symfony/http-kernelPackagist
From 2.6.0 · fixed in 2.6.6