Skip to main content
← All vulnerabilities
CVE-2015-2273GHSA-W77V-XPXR-C6PV

Cross-site scripting (XSS) vulnerability in mod/quiz/report/statistics/statistics_question_table.php in Moodle through 2.5.9, 2.6.x before 2

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.9, 2.7.6, 2.8.4
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in mod/quiz/report/statistics/statistics_question_table.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the student role for a crafted quiz response.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.9

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.6

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.4

References 3

git.moodle.org

moodle.org

openwall.com