Skip to main content
← All vulnerabilities
CVE-2015-2267GHSA-CM4R-58PJ-H2PH

mdeploy.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to byp

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.9, 2.7.6, 2.8.4
None on Exploit-DB, Metasploit or GitHub

Summary

mdeploy.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to bypass intended access restrictions and extract archives to arbitrary directories via a crafted dataroot value.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.9

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.6

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.4

References 3

git.moodle.org

moodle.org

openwall.com