Netsweeper < 4.0.11 / 4.1.5 Reflected XSS via view_server_log.php
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.0.11, 4.1.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Netsweeper web filtering software (versions before 4.0.11 and 4.1.x before 4.1.5) is affected by a reflected cross-site scripting flaw in its web administration interface. An attacker who tricks an administrator into opening a crafted link could run arbitrary JavaScript in that user's browser session.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Netsweeper before 4.0.11 and 4.1.0 before 4.1.5 contains a reflected cross-site scripting vulnerability in webadmin/reporter/view_server_log.php that allows remote attackers to execute arbitrary JavaScript by injecting malicious code through the log request parameter, which is reflected into the HTML response without output encoding. Attackers can craft a malicious URL and induce a user to request it, resulting in arbitrary JavaScript execution within the victim's browser session against the Netsweeper web administration interface. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- Netsweeper Netsweeper
fixed in 4.0.11; From 4.1.0 · fixed in 4.1.5